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FAQs of ITC-04 Offline Utility  

About Form GST ITC-04 Offline Utility 

Download Form GST ITC-04 Offline Utility 

Worksheet Tabs in Form GST ITC-04 Offline Utility 

Entering Details in Offline Utility  

Upload the Generated JSON File 

Download Error JSON File 

 

 

Form GST ITC-04 Offline utility is an Excel-based tool to help taxpayers to prepare their Form 

GST ITC-04 declaration offline. Taxpayers may use the offline utility to furnish details of 

goods/capital goods sent to job worker and received back etc. in every Quarter. 
 

2. Who needs to file GST ITC-04 Offline Utility?  

 
A registered person (Principal) is required to file a declaration in ‘Form GST ITC-04’ every quarter, 

within the prescribed time, if the principal is sending any inputs or capital goods to a job worker 

(both registered and unregistered) without payment of tax and receives it back or sends it out to 

another job worker or supplies from premises of job worker to customer directly. 
 

3. What are the features of Form GST ITC-04 Offline Utility?  

 
The Key Features of Form GST ITC-04 Offline Utility are given below: 

• Details of Table 4, 5A, 5B and 5C can be prepared offline with no connection to Internet. 

• Most of the data entry and business validations are inbuilt in the offline utility reducing  

chances of errors upon upload to GST Portal. 

4. Can I file Form ITC-04 using Offline Utility?  

1. What is Form GST ITC-04 Offline Utility? 

About Form GST ITC-04 Offline Utility 
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No. Filing can take place only online on the GST Portal. Using Offline Utility, you will be able to 

prepare details of  Table 4, 5A, 5B and 5C of Form GST ITC-04. Once, you have uploaded the 

prepared details on the GST Portal, you must file return on the portal with your Login credentials. 

 

 

Details for following Tables of Form GST ITC-04 can be entered by taxpayer using the offline 

Tool: 

• Table 4:  Details of inputs/capital goods sent for job -work 

• Table 5A: Details of inputs/ capital goo ds received back from job worker to whom such 

goods were sent for job work; and losses and wastes 

• Table 5B: Details of inputs / capital goods received back from job worker other than the 

job worker to whom such goods were originally sent for job work; and losses and wastes 

• Table 5C: Details of inputs/ Capital goods sent to job worker and subsequently supplied 

from premises of job worker; and losses and wastes 

 

 

To download and open the Form GST ITC-04 Offline Utility in your system from the GST Portal, 

perform following steps: 

1. Access the GST Portal: www.gst.gov.in. 

2. Go to Downloads > Offline Tools > ITC-04 Offline Tool option and click on it. 

3. Unzip the downloaded Zip file which contain ITC_04_Offline.xls excel sheet. 

4. Open the ITC_04_Offline.xls excel sheet by double clicking on it. 

5. Read the ‘Instruction_sheet’ instructions on excel sheet and then fill the worksheet 

accordingly. 

 
Note: Downloading the ITC-04 Offline utility is a one-time activity. However, the utility may get 

updated in future. So, always use the latest version available on the GST Portal.  

 

 

No. You can download the Form GST ITC-04 Offline Utility under ‘Downloads’ section, without 

logging in to the GST Portal. 

5. What details in Form GST ITC-04 can be entered by taxpayer using the 

Offline Utility? 

6. From where can I download and use the Form GST ITC-04 Offline Utility 

in my system? 

Download Form GST ITC-04 Offline Utility 

7. Do I need to login to GST Portal to download Form GST ITC-04 Offline 

Utility? 

http://www.gst.gov.in/
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The offline functions work best on Windows 7 and above and MS EXCEL 2007 and above. 
 

 

As of now, Form GST ITC-04 Offline utility cannot be used on mobile. It can only be used on 

desktop/laptops. 

 

 

While Opening the Excel sheet, if you see error message box like: "Compilation error in module 

due to incompatibility with the version, platform or architecture" please ignore this message and 

see if excel sheet works or not. In case it does not work, you need to use latest MS Office for 

successful export of your data. 

 

 

There are 6 worksheet-tabs in ITC-04 Offline Utility. These are: 

1. Instruction_Sheet 

2. Home 

3. Table 4 

4. Table 5A 

5. Table 5B 

6. Table 5C 
 

12. What is the use of “Instruction_Sheet” worksheet-tab?  

 
The “Instruction_Sheet” sheet contains Introduction and help instructions for you to read and 

use them to easily fill data in Form GST ITC-04 Offline Utility. 

13. What is “Home” button?  

8. What are the basic system requirements/configurations required to use 

Form GST ITC-04 Offline Tool? 

9. Is Offline utility mobile compatible? 

10.I am getting error message as “Compilation error in module due to 

incompatibility with the version, platform or architecture” while opening 
the offline tool. What to do now? 

11.How many worksheet-tabs are there in Form GST ITC-04 Offline 

Utility? 

Worksheet Tabs in Form GST ITC-04 Offline 

Utility 
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On click of ‘Home’, offline utility navigates to the Home sheet. 

 

 

After entering the data in each sheet, you must click on ‘Validate Sheet’ button to validate the records. If  

there are any errors, then those errors will be displayed in ‘Sheet validation errors’ column. You must 

correct these errors before you move to next sheet or generate JSON file to upload. 

 

 

The Home sheet is the main page of the utility. It is used to perform following 4 functions: 

1. Enter mandatory details - GSTIN of Principal, SEZ Unit/Developer, Financial Year and 

Return Period - Without entering these details, you will not be able to validate the data 

which you entered in various worksheets and also you will not be able to generate the 

JSON file. 

2. Generate JSON file, for upload of Form GST ITC-04 return details, prepared offline on 

GST portal, using Generate JSON File to upload button. 

3. Import and open Error JSON File downloaded from GST portal using Open Downloaded 

ITC-04 JSON/Error File button. 

 

 

The Table 4 sheet is used to perform following 3 functions: 

1. Enter details of inputs/capital goods sent for job-work. 

2. Validate the entered details using the Validate Sheet button. 

3. Navigate to the Home page by clicking on the Home button or navigate to the next sheet. 
 

 

The Table 5A sheet is used to perform following 3 functions: 

1. Enter details of inputs/ capital goods received back from job worker to whom such goods 

were sent for job work; and losses and wastes. 

2. Validate the entered details using the Validate Sheet button. 

3. Navigate to the Home page by clicking on the Home button or navigate to the next sheet 
 

 

The Table 5B sheet is used to perform following 3 functions: 

1. Enter details of inputs / capital goods received back from job worker other than the job  

worker to whom such goods were originally sent for job work; and losses and wastes.  

14. What is “Validate Sheet” button? 

15. What is the use of “Home” worksheet-tab? 

16. What is the use of ‘Table 4’ worksheet-tab? 

17. What is the use of ‘Table 5A’ worksheet-tab? 

18. What is the use of ‘Table 5B’ worksheet-tab? 



 
 

ITC-04 Off line Utility (Last Updated on: 12th August, 2019) 

Designed and Developed by GSTN Page 7 of 45 

 

 

2. Validate the entered details using the Validate Sheet button. 

3. Navigate to the Home page by clicking on the Home button or navigate to the next sheet 
 

19. What is the use of ‘Table 5C’ worksheet-tab?  

 
The Table 5C sheet is used to perform following 3 functions: 

1. Enter details of inputs/ Capital goods sent to job worker and subsequently supplied 

from premises of job worker; and losses and wastes. 

2. Validate the entered details using the Validate Sheet button. 

3. Navigate to the Home page by clicking on the Home button or navigate to the next sheet 
 
 
 

20. How can I prepare details in Offline Utility?  

 
For preparing details in Offline Utility, download the utility from GST Portal and fill up required  

details, create JSON file and then upload it on the GST Portal. 

 

 

No, the offline utility cannot populate name of the taxpayer based on GSTIN, as details will not be 

there to fetch name of the taxpayer in Excel/offline utility. However, it can validate structure of 

GSTIN when GSTIN is entered in “Home” sheet of Offline utility. 

22. Can I enter negative or decimal amounts in the offline utility?  

 
You cannot enter any negative values in the offline utility. However, you can enter values upto 

two decimal point. 

 

23. Can the offline utility validate all details entered in it?  

 
No, the offline utility will not be able to validate all the details as it would have no connection with 

GST portal at the time of data entry. Only limited validations would be available in the offline utility 

tool, namely: GSTIN structure, type of tax etc. 
 

Entering Details in Offline Utility 

21.Can the offline utility populate name of the taxpayer based on GSTIN 

in “Home” Sheet? 

24.After clicking “Validate Sheet” button, I can see cells highlighted in 
red and “Sheet Validation” column only shows “Error in row”. How I can 

know details about the error? 
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Point your mouse-cursor on each of the red-highlighted cells to read the error description of each 

cell. A yellow description box will appear. Correct the errors as mentioned in the description box. 

Alternatively, click Review > Show All Comments link in the ribbon-tab of the excel to view all 

the comments together. 
 

25.  When will I be able to validate all details entered in the offline utility?  

 
Most of the validations are made available in the offline tool itself on click of “Validate Sheet” 

button. The validations that have dependency of online connectivity like GSTIN validation would 

be done at the time of upload of JSON File created using offline tool. 
 

 

Yes. You must login in to the GST Portal to upload the generated JSON file using Form GST ITC- 

04 Offline Utility. 

 

 

If some details do not exist from previous upload, all new details will be added as new entries. In 

case, some details exist from previous upload, it will be updated with latest uploaded details.  
 

 

No. You can’t generate nil JSON file. 

 

Download Error JSON File  

29. What will the error report contain?  

 
Error Report will contain only those entries that failed validation checks on the GST portal. The 

successfully-validated entries can be previewed online. 
 

26.Do I need to login to GST Portal to upload the generated JSON file 
using Form GST ITC-04 Offline Utility? 

Upload the Generated JSON File 

27.I am uploading Form GST ITC-04 JSON File again, after making 

changes. What will happen to details of the previous upload? 

28.Can I generate the JSON file from the offline utility without entering 

any details in any sheet? 

30.Does the downloaded Error JSON File contain all the entries I have 

uploaded on the GST Portal? 
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No, the downloaded Error JSON File contains only those entries, of that specific table that has 

failed validation during upload on the GST portal. 
 

 

No, it is not necessary for you to download the ITC-04 JSON File processed without error. You 

need to download it only if you want to view or update the details added previously.  

 

 

Yes. Please refer to the following list of Do’s and Don’ts for your easy reference: 

 

Before Generating JSON File… 

Do’s Don’ts 

Enter a valid GSTIN very carefully. Verify 

GSTIN from the GST portal: Home > Search 

Taxpayer > Search by GSTIN/UIN, and 

make sure the GSTIN registration is active 

Don’t type the alphabet ‘O’ in place of the 

number ‘0’. 

You can use the Copy/Paste (Ctrl+C/Ctrl+V) 

keyboard functions while entering data in the 

utility. 

Don’t use the Cut (Ctrl+X) keyboard function 

while entering data in the utility. 

------- Don’t forget to click Validate Sheet button 

after making changes in any of the sheets. 

You may change the file name and location 

of the generated JSON file. 

Don’t change the extension (.json) of the 

generated JSON file. 

Enter the challan number in every row. The 

row is valid only if there is any challan 

number. File generation will not read the 

details after the row where challan number is 

not given. 

------- 

You need to start writing data from ROW 7. 

JSON creation won't read any data entered 

after skipping any row. So, please fill your 

invoice details in continuous manner. 

DO NOT SKIP any row. 

31.I’ve uploaded Form GST ITC-04 JSON File and it was processed 
without error. Do I need to download the generated file? 

32.Is there a list of key Do’s and Don’ts we need to keep in mind while 

making entries in the utility? 
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You need to empty the sheet(s) before 

importing any file. 

------- 
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ITC-04 Offline utility is an Excel-based tool to help taxpayers to prepare his Form GST ITC-04 

declaration offline. Taxpayers may use the offline utility to furnish details of goods/capital goods 

sent to job worker and received back in every Quarter as per CGST Rules.  

 

Details for following tables of Form GST ITC-04 can be entered by taxpayer using the 

offline Tool: 

• Table 4: Details of inputs/capital goods sent for job-work 

• Table 5A: Details of inputs/ capital goods received back from job worker to whom such 

goods were sent for job work; and losses and wastes 

• Table 5B: Details of inputs / capital goods received back from job worker other than the 

job worker to whom such goods were originally sent for job work; and losses and wastes 

• Table 5C: Details of inputs/ Capital goods sent to job worker and subsequently supplied 

from premises of job worker; and losses and wastes 
 

Once return is prepared using offline utility, it is to be uploaded on GST Portal by creating a JSON 

file and then you can file Form GST ITC-04. 

 
To Prepare Return in Form ITC-04 using offline utility, perform following steps: 

 
A. Download the Form GST ITC-04 Offline Utility 

B. Open the Form GST ITC-04 Offline Utility Excel Worksheet 

C. Add table-wise details in the Worksheet 

D. Generate JSON File to upload 

E. Upload the generated JSON File on GST Portal 

F. File Form GST ITC-04 on the GST Portal 

G. Download Error Report, if any 

H. Open Downloaded Error Form GST ITC-04 JSON File(s) 

I. Download ITC-04 JSON file, if any 

ITC-04 Offline Utility Overview 

Manual of ITC-04 Offline Utility 



 
 

ITC-04 Off line Utility (Last Updated on: 12th August, 2019) 

Designed and Developed by GSTN Page 12 of 45 

 

 

 

Flow chart for using Form GST ITC-04 Offline Tool  
 
 
 

 

 
Open Downloaded Error 
Form GST ITC-04 JSON 

File(s) and make 
corrections, generate 
JSON and upload the 

generated JSON on GST 
Portal 

 
 
 

Download Error Report, if  
any 

 
 

Online File Form GST 
ITC-04 on the GST 
Portal 

 
 

Upload the generated 
JSON File on GST 
Portal 

 
 
 

Generate JSON File to 
upload 

 
 

Add table-wise details 
in the 
Worksheet 

 
 

Open the Form GST 
ITC-04 Off line Utility 

Excel Worksheet 

 
 

Download the Form GST 
ITC- 04 Off line 
Utility 
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A. Download the Form GST ITC-04 Offline Utility  

 
To download the Form GST ITC-04 Offline Utility, perform following steps: 

 
Downloading the Form GST ITC-04 Offline utility is a one-time activity. However, the 

utility may get updated in future. So, always use the latest version available on the GST 

Portal. 

 
1. Access the www.gst.gov.in URL. The GST Home page is displayed. 

 

2. Click the Downloads > Offline Tools > ITC-04 Offline Tool option. 

 

 
You can download the ITC-04 Offline Utility from the Portal without logging in to the GST 

Portal. 

 

3. ITC-04 Offline Tool page is displayed. Click the Download hyperlink. 

 
Make sure you carefully read the Important message and System Requirement details 

displayed on the page. 

 
 

 
 

 
 

http://www.gst.gov.in/
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4. An Information popup opens. Click PROCEED. 
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5. Zipped ITC-04 Offline Utility folder gets downloaded. 

 

 
Go back to the Main Menu 
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B. Open the Form GST ITC-04 Offline Utility Excel Worksheet  

 
To open the downloaded Form GST ITC-04 Offline Utility Excel Worksheet, perform following 

steps: 

 
1. Extract the files from the downloaded zipped folder ITC_04_Offline_Utility.zip and you will see 

ITC_04_Offline excel file in the unzipped folder. Right-click and click Open. 

 

 
2. Click Enable Editing. Without Enabling editing, no entry can be made in excel sheet. 
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3. Click Enable Content. Then, click the Instruction Sheet tab. 

 

 

 
The Worksheet comprises of 6 tabs—Instruction Sheet, Home, Table 4A, Table 

5A, Table 5B and Table 5C.  
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4. Instruction Sheet page is displayed. It contains introduction and help instructions. Scroll 

down to read all the instructions carefully. Once you have completed your reading, you can 

now proceed to enter details in the worksheet. 

 
 

Go back to the Main Menu 
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C. Add table-wise details in the Worksheet  

 
To add table-wise details in the Worksheet, perform following steps: 

 
1. Go to the Home tab. 

2. In the GSTIN of Manufacturer f ield, enter your GSTIN. 

3. In case, you are a SEZ Unit/ Developer, select Yes from SEZ Unit/Developer drop-down list. 

Or else, select No. 

4. Select the applicable Financial Year from the drop-down list. 

5. Select the applicable Return Period for which Form GST ITC-04 is filed, from the drop-down 

list. 

 

 
Note: 

Open Downloaded ITC-04 JSON/ Error File: To import the data file or the error file, 

downloaded from the GST Portal (in .json format) and open it in Offline tool for modification. 

Import will auto populate the details in the Offline tool. 

Generate JSON File to upload: To create the data file (in .json format) of details and 

modifications as done in Offline tool. The JSON file can be uploaded on the GST Portal after 

logging in. 

 
6. Go to the Table 4 tab and enter details of inputs/ capital goods sent for job-work. 

Note: The table below provides the worksheet name, table name and detailed description for 

this worksheet. 
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7. Once the details are entered, click the Validate Sheet button. 

 

 

 
8. In case of unsuccessful validation, error-intimation popup will appear and the cells with error 

will be highlighted. Close the popup by clicking OK. 
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9. The comment box for each cell, that has errors, will show the error message. The user 
can read the error description of each cell and correct the errors as mentioned in the 
description box. 

 

 
 

Note: Alternatively, click the Review ribbon-tab > Show All Comments link to view the 
comments for fields with errors. 

 

 
10. After you have corrected all the errors, again click the Validate Sheet button. 
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11. A popup Message box appears “Sheet successfully validated. No error(s) found”. Click OK. 

 

 
12. Go to the Table 5A tab and enter details of inputs/ capital goods received back from job worker 

to whom such goods were sent for job work; and losses and wastes. 

Note: The table below provides the worksheet name, table name and detailed description for 

this worksheet. 
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13. Once the details are entered, click the Validate Sheet button. In case of any errors, follow the 

steps as mentioned earlier to correct the errors. 

 

 
14. A popup Message box appears “Sheet Successfully Validated. No error(s) found. Click OK. 
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15. Go to the Table 5B tab and enter details of inputs / capital goods received back from job 

worker other than the job worker to whom such goods were originally sent for job work; and 

losses and wastes. 

Note: The table below provides the worksheet name, table name and detailed description for 

this worksheet. 

 

 

 
16. Once the details are entered, click the Validate Sheet button. In case of any errors, follow the 

steps as mentioned earlier to correct the errors. 

 

 
17. A popup Message box appears “Sheet Successfully Validated. No error(s) found. Click OK. 
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18. Go to the Table 5C tab and enter details of inputs/ Capital goods sent to job worker and 

subsequently supplied from premises of job worker; and losses and wastes.  

Note: The table below provides the worksheet name, table name and detailed description for 

this worksheet. 

 

 
19. Once the details are entered, click the Validate Sheet button. In case of any errors, follow the 

steps as mentioned earlier to correct the errors. 
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20. A popup Message box appears “Sheet Successfully Validated. No error(s) found. Click OK. 

 

 
Go back to the Main Menu 
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D. Generate JSON File to upload  

 
To generate JSON File to upload, perform following steps: 

 
1. From the tab, you are on, go to the ‘Home’ sheet by either clicking the ‘Home’ button or clicking 

the ‘Home’ sheet. 

 

 
2. Click the Generate JSON File to upload button to create the data file (in .json format) of 

details and modifications as done in Offline tool. The JSON file can be uploaded on the GST 

Portal after logging in. 

 

 
3. A success message is displayed as shown in the screenshot below. Click Ok. 
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4. A Save As pop-up window appears. Select the location where you want to save the JSON 

file, enter the file name and click the SAVE button. 

 

 
Go back to the Main Menu 
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E. Upload the generated JSON File on GST Portal  

 
To upload the generated JSON File on the GST Portal, perform following steps: 

 
1. Access the www.gst.gov.in URL. The GST Home page is displayed. 

2. Login to the portal with valid credentials. 

3. Click the Services > Returns > ITC Forms option. 

 

 
4. The GST ITC Forms page is displayed. 

5. In the GST ITC-04 tile, click the PREPARE OFFLINE button. 

 

 

 

http://www.gst.gov.in/
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Form GST ITC-04 is required to be filed on a quarterly basis for tax periods until September 2021.  

However, with effect from 1st October 2021, it is required to be filed on half yearly or annual  

basis depending upon the aggregate turnover of preceding financial year: 

(1) Those with an annual aggregate turnover of more than Rs.5 crore – Half-yearly from  

April-September- and October-March.  
(2) Those with an annual aggregate turnover of up to Rs.5 crore – Yearly from FY 2022-23. 

 

 
 

6. Select the Financial year and Return Filing Period from the drop-down list. 

7. Click the SEARCH button. 

 

 
8. The Upload section of the Offline Upload and Download for ITC 04 page is displayed. Click 

the Choose File button. 
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9. Browse and navigate the JSON file to be uploaded from your computer. Click the Open 

button. 
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10. The Upload section page is displayed. A green message appears confirming successful 

upload and asking you to wait while the GST Portal validates the uploaded data. And, below 

the message, is the Upload History table showing Status of the JSON file uploaded so far. 
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11. In case, there was some error in data uploaded, like Invalid GSTIN etc., then the Upload 

History table will show the Status of the JSON file as “Error Occurred”. Rectify the error and 

upload the JSON file again by following the steps mentioned in the hyperlink to download 

error report, if any: Download Error Report, If any 

 

Go back to the Main Menu 
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F. File Form GST ITC-04 on the GST Portal  

 
To file Form ITC-04 on the GST Portal, perform following steps: 

 
1. Access the www.gst.gov.in URL. The GST Home page is displayed. 

2. Login to the portal with valid credentials. 

3. Click the Services > Returns > ITC Forms command. 

 

 
4. The GST ITC Forms page is displayed. 

5. In the GST ITC-04 tile, click the PREPARE ONLINE button. 

 

http://www.gst.gov.in/
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6. Select the Financial year and Return Period from the drop-down list. 

7. Click the SEARCH button. 

 

 
 
Form GST ITC-04 is required to be filed on a quarterly basis for tax periods until September 2021.  

However, with effect from 1st October 2021, it is required to be filed on half yearly and or annual basis 
depending upon based on the aggregate turnover of preceding financial year: 

(1) Those with an annual aggregate turnover of more than Rs.5 crore – Half-yearly from  
April-September- and October-March. 

(2) Those with an annual aggregate turnover of up to Rs.5 crore – Yearly from FY 2022-23. 

 
8. Details for the selected Tax period are displayed. You can also edit or delete the details 

before filing the return. 

9. Click FILE RETURN button. 
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10. Select the checkbox. 

11. Select the Authorized signatory from the drop-down list. 

12. Click the FILE WITH DSC or FILE WITH EVC button. 
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13. Once the Verification is completed, ARN will be generated and status is changed to Filed. 

 

 
 

Go back to the Main Menu 
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G. Download Error Report, if any  

 
To download the Error report, if any, while uploading ITC-04 JSON File for correcting entries, that 

failed validation on the GST portal, perform following steps: 

 
1. Error Report will contain only those entries that failed validation checks on the GST Portal. 

The successfully-validated entries can be previewed online. Click Generate error report 

hyperlink. 

 

 
2. A confirmation-message is displayed and Columns Status and Error Report change as shown 

below. 

 

 
3. Once the error report is generated, Download error report link is displayed in the Column 

Error Report. Click the Download error report link to download the zipped error report. 
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4. The error JSON File is downloaded on your machine. Error Report will contain only those 

entries that failed validation checks on the GST portal. 

 

 
5. Unzip and save the JSON File in your machine. 

 

 
6. Import the JSON file into the offline utility and make updates as necessary, as explained 

below. Open Downloaded ITC-04/ Error ITC-04 JSON File(s) 

 

Go back to the Main Menu 
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H. Open Downloaded ITC-04/ Error ITC-04 JSON File(s)  

 
To open the downloaded ITC-04/ Error ITC-04 JSON File to make any changes to data or for 

correcting entries that failed validation on the GST portal, perform following steps:  

 
1. Open ITC-04 Offline Utility and go to the Home tab. Click the Open Downloaded ITC-04 

JSON/Error button. 

 

 

 
2. A file dialog box will open. Navigate to extracted error file. Select the file and click the Open 

button. 
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3. Success message will be displayed. Click the OK button to proceed. 

 

 
4. Navigate to individual sheets. Correct the errors, as mentioned in the column “GST Portal 

Validation Errors” in each sheet. 



 
 

ITC-04 Off line Utility (Last Updated on: 12th August, 2019) 

Designed and Developed by GSTN Page 42 of 45 

 

 

 

 
 

5. After making corrections in a sheet, click the Validate Sheet button to validate the sheet. 

Similarly, make corrections in all sheets and click the Validate Sheet button in each sheet. 

6. From the tab you are on, go to the Home tab by either clicking the Home button or clicking 

the Home tab to generate summary. Follow steps mentioned in the following hyperlinks to 

generate and upload the JSON file: Generate JSON File to upload and Upload the 

generated JSON File on GST Portal. 

 

Go back to the Main Menu 
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I. Download ITC-04 JSON file, if any  

 
To download the ITC-04 JSON file, to make any updates in the Offline tool, perform following 

steps: 

Note: 

If some details do not exist from previous upload, all new details will be added as new entries. In 

case, some details exist from previous upload, it will be updated with latest uploaded details.  

 
1. Click Download tab. 

 

 
2. Click GENERATE JSON FILE TO DOWLOAD hyperlink. 

 

 
3. A confirmation-message is displayed as shown. 
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4. Click the link as shown below to download the JSON file. 

 

 
5. The JSON File is downloaded on your machine. 

 

 
6. Unzip and save the JSON File in your machine. 
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7. Import the JSON file into the offline utility and make updates as necessary, as explained 

below. Open Downloaded ITC-04/ Error ITC-04 JSON File(s) 

 

Go back to the Main Menu 


